Bug Tracker

Opened 8 years ago

Closed 7 years ago

#2462 closed bug (duplicate)

backgroundPosition propertie

Reported by: ragamo Owned by:
Priority: major Milestone: 1.2.4
Component: core Version: 1.2.2
Keywords: Cc:
Blocked by: Blocking:

Description

.css({ backgroundPosition: ... doesn't work!

Change History (7)

comment:1 follow-up: Changed 8 years ago by flesler

It is working for me, do you have a test case ? at least tell us what browser/OS are you using and how are you setting the background position, and why do you say it doesn't work ? you don't see the change visually ? or something else.

comment:2 in reply to: ↑ 1 Changed 8 years ago by ragamo

Replying to flesler:

It is working for me, do you have a test case ? at least tell us what browser/OS are you using and how are you setting the background position, and why do you say it doesn't work ? you don't see the change visually ? or something else.

Doh! Yes it is working! no bug here! xD Seems i have commited an human error xD

Close this please

comment:3 Changed 8 years ago by davidserduke

  • Resolution set to worksforme
  • Status changed from new to closed

Closed on request of author.

comment:4 Changed 7 years ago by kswedberg

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Hi Ariel, I'm reopening this ticket because there is a discrepancy between browsers:

IE6 and IE7 return undefined for css('backgroundPosition') but return correct results for css('backgroundPositionX') and css('backgroundPositionY').

FF3 returns correct results for css('backgroundPosition') but returns empty string for css('backgroundPositionX') and css('backgroundPositionY').

Safari3 returns correct results for all three.

Here is a test page: http://test.learningjquery.com/background-position.html

comment:5 Changed 7 years ago by sauy7

Test cases and a potential fix here: http://heighes.com/tests/jquery/

comment:6 Changed 7 years ago by moneal

FF2 only seems to work if it has been set with jQuery. Not if its been set with a external style sheet.

comment:7 Changed 7 years ago by brandon

  • Resolution set to duplicate
  • Status changed from reopened to closed

duplicate of #4295

Note: See TracTickets for help on using tickets.