Bug Tracker

Opened 7 years ago

Closed 5 years ago

Last modified 4 years ago

#3342 closed feature (wontfix)

Support POST for cross-domain AJAX requests

Reported by: HonestQiao Owned by: HonestQiao
Priority: low Milestone: 1.5
Component: ajax Version: 1.4.4
Keywords: CORS XMLHttpRequest XDomainRequest Cc: snover
Blocked by: #7195 Blocking:

Description

Cross-Domain Ajax POST Patch for jQuery 1.2.5

  1. function:

jQuery.Ajax can post to cross-domain

  1. install:

files:patch_for_jQuery 1.2.5.txt index.html ajax_post.php modify 'site.com' to you domain.

  1. visit index.html

Attachments (1)

cross-domain_ajax_post.zip (3.3 KB) - added by HonestQiao 7 years ago.
Patch file

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by HonestQiao

Patch file

comment:1 Changed 7 years ago by flesler

  • Cc HonestQiao flesler added
  • Milestone changed from 1.2.5 to 1.3
  • need changed from Patch to Review

Ok, thanks for all the data. So you propose to create an iframe, add a form, include as many input elements as POST fields and submit it.

IMO it may work, but seems like an aggressive approach to do such a thing. Adding iframes can cause unexpected behaviors.

I'll ask around, thanks.

comment:6 Changed 5 years ago by rwaldron

  • Priority changed from major to low
  • Resolution set to wontfix
  • Status changed from new to closed

This patch is way out of date.

comment:7 Changed 5 years ago by rwaldron

  • Milestone 1.3 deleted
  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:8 Changed 5 years ago by rwaldron

  • Cc snover added; HonestQiao flesler removed
  • Owner set to HonestQiao
  • Status changed from reopened to pending

Please provide an updated patch for this request.

comment:9 Changed 5 years ago by snover

  • Keywords CORS XMLHttpRequest XDomainRequest added; Croos-Domain POST removed
  • Status changed from pending to open
  • Summary changed from Cross-Domain Ajax POST Patch for jQuery 1.2.5 to Support POST for cross-domain AJAX requests
  • Version changed from 1.2.5 to 1.4.3

comment:10 Changed 5 years ago by snover

  • Blocked by 7195 added

comment:11 Changed 5 years ago by rwaldron

  • Keywords ajaxrewrite added

comment:12 Changed 5 years ago by snover

  • Keywords changed from CORS,XMLHttpRequest,XDomainRequest,ajaxrewrite to CORS XMLHttpRequest XDomainRequest ajaxrewrite

comment:13 Changed 5 years ago by jaubourg

You can already do that on browsers that support cors (jQuery.support.cors) with no iframe hacks. With the new architecture, adding an iframe based transport shouldn't be an issue but clearly is best suited for a plugin imo.

comment:14 Changed 5 years ago by jitter

  • Keywords ajaxrewrite removed
  • Milestone set to 1.5
  • Resolution set to wontfix
  • Status changed from open to closed
  • Version changed from 1.4.3 to 1.4.4

The new ajax rewrite makes it easy to write a plugin which provides a transport to handle cross-domain request cross-browser. For the moment being this won't be done in core directly and thus is best suited for a plugin.

comment:15 Changed 5 years ago by jitter

#8283 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.